My Blog List

  • Majeshir Anupras Alankar - मराठी भाषा सौंदर्याने नटलेली आहे. तिला अनेक अलंकार प्राप्त आहेत. त्यापैकी अनुप्रास हा एक शब्दालंकार. एखाद्या वाक्यात किंवा कवितेच्या चरणामध्ये जेव्हा एका...
    3 years ago

Friday, October 29, 2010

Understanding Nexus -- Part 15 -- MST

MST is defined in IEEE 802.1s. MST maps multiple VLANs into “instances” that maintain their own STP topology.
  • You can have up to 65 MST instances on one device.
  • MST is compatible with 802.1d and 802.1w
  • You can configure MST to send pre-standard BPDU using the "spanning-tree mst pre-standard" interface command
  • The MST configuration for a single region must have the same Name, Revision Number, and VLAN-to-MST Instance Mapping

Enabling MST

switch# config t
switch(config)# spanning-tree mode mst

Entering MST Configuration Mode

switch(config)# spanning-tree mst configuration
switch(config-mst)#

Configuring MST Parameter

switch(config-mst)# name accounting
- Specifies the name for the MST region. The name string has a maximum length of 32 characters and is case sensitive. The default is an empty string

switch(config-mst)# revision 5
- Specifies the revision number for the MST region. The range is from 0 to 65535, and the default value is 0.

switch(config-mst)# instance 1 vlan 10-20
- For instance-id, the range is from 1 to 4094.

Configuring MST Root Bridge

switch# config t
switch(config)# spanning-tree mst 5 root primary
switch(config)# spanning-tree mst 5 root secondary
switch(config)# spanning-tree mst 5 priority 4096

Understanding Nexus -- Part 14 -- STP in Nexus

For most of the people, STP on Nexus is quite confusing. This post is just for them to elaborate the STP functions as well as to answer some of the frequently asked questions.

STP was implemented to provide a loop-free connectivity at Layer 2 network. Later it got updated to Rapid STP. And Cisco has it's own implementation standard which is known as Rapid PVST+, which is default on Nexus.

All other things like Election of Root Bridge and all are same as in IOS. So if you are familiar with it, you got the same mechanism in Nexus.

You can run either Rapid PVST+ or MST within each virtual device context or in switch (VDC - we will discuss it later). You cannot run both STP modes simultaneously in a VDC.

Both MST and Rapid PVST+ on Nexus are backward compatible with switches running PVST+.

MST interoperates with switches running PVST+ and Rapid PVST+ by leveraging PVST+ simulation. PVST simulation is enabled by default on Nexus systems running MST. The standard compliant MST can also interoperate with Cisco's pre-standard MSTP.

When pre-standard BPDUs are received, the Nexus system translates the BPDU contents to IEEE 802.1Q MSTP format for processing. As a result, the 2 MST regions will merge into one and no MST region boundary will be formed.

However, there are a few exceptions where a MST region boundary will be formed on links where switches with Cisco's pre-standard MSTP are connected.

Some differences exist in STP feature support between NX-OS and IOS. These differences include:
  • The NX-OS only support Rapid-PVST+ and MST.
  • PVST+, MISTP and VLAN bridge are not supported.
  • Since PVST+ is not supported, Backbonefast and uplinkfast are not supported
  • Each VDC will only support a single STP. However, different STP (Rapid PVST+ or MST) can be enabled on separate virtual device context (VDC).
  • Both NX-OS and Native IOS 12.2(33)H and later release support standard compliant MST. Prior to 12.2(33)H release, the software only support prestandard MST.
  • Introduction of Spanning-tree port types configuration which include edge (portfast), network (inter-switch) and normal. The introduction of port type edge change portfast related IOS commands However, the NX-OS will accept the command in IOS format and convert it to NX-OS format.
  • Dispute mechanism is enabled by default.
  • Bridge Assurance (BA) is enabled by default. The feature is operational only on ports configured as STP network type.
  • PVST simulation can be disabled to detect and avoid accidental connection to switches configured with Rapid-PVST and PVST+.
  • Nexus system does not recalculate STP cost after physical member ports were shut down.
Overview

Rapid PVST+ provides for rapid recovery of connectivity for edge ports, new root ports, and ports connected through point-to-point links as follows:

Edge ports — immediate transitions to the forwarding state. (same as previously known Cisco-proprietary feature named PortFast.)
Root port — If Rapid PVST+ selects a new root port, it blocks the old root port and immediately transitions the new root port to the forwarding state.
Point-to-point links — If you connect a port to another port through a point-to-point link and the local port becomes a designated port, it negotiates a rapid transition with the other port by using the proposal-agreement handshake to ensure a loop-free topology.

Rapid PVST+ achieves rapid transition to the forwarding state only on edge ports and point-to-point links.

Protocol Timers
Variable Description
Hello timer Determines how often each device broadcasts BPDUs to other network devices. The default is 2 seconds, and the range is from 1 to 10.
Forward delay timer Determines how long each of the listening and learning states last before the port begins forwarding. This timer is generally not used by the protocol, but it is used when interoperating with 802.1D spanning tree. The default is 15 seconds, and the range is from 4 to 30 seconds.
Maximum age timer Determines the mount of time protocol information received on a port is stored by the network device. This timer is generally not used by the protocol, but it is used when interoperating with 802.1D spanning tree. The default is 20 seconds; the range is from 6 to 40 seconds.

 

Port Roles

Rapid PVST+ provides rapid convergence by assigning port roles. Rapid PVST+ select the device with the highest switch priority (lowest numerical priority value) as the root bridge.

Root Port — Provides the best path (lowest cost) towards the root bridge.

Designated Port — Connects to the designated device that has the lowest path cost when forwarding packets from that LAN to the root bridge. The port through which the designated device is attached to the LAN is called the designated port.

Alternate port — Offers an alternate path toward the root bridge. An alternate port provides a path to another device in the topology.

Backup port — Acts as a backup for the path provided by a designated port toward the leaves of the spanning tree. A backup port can exist only when two ports are connected in a loopback by a point-to-point link or when a device has two or more connections to a shared LAN segment. A backup port provides another path in the topology to the device.

Disabled port — Has no role within the operation of the spanning tree.

 

 

 

 

Rapid PVST+ Port State
Each Layer 2 LAN port on the device that uses Rapid PVST+ or MST exists in one of the following four states:
Blocking—The Layer 2 LAN port does not participate in frame forwarding.
Learning—The Layer 2 LAN port prepares to participate in frame forwarding.
Forwarding—The Layer 2 LAN port forwards frames.
Disabled—The Layer 2 LAN port does not participate in STP and is not forwarding frames.


When the STP algorithm places a Layer 2 LAN port in the forwarding state, the following process occurs:
1. The port is put into blocking state while it waits for protocol information that suggests it should go to the learning state.
2. The port waits for the forward delay timer to expire, then moves to the learning state, and restarts the forward delay timer.
3. In the learning state, the port continues to block data frames, as it learns the mac address information of the end-stations for the forwarding database.
4. The port waits for the forward delay timer to expire and then moves to the forwarding state, where both learning and frame forwarding are enabled.

 

Blocking State
Does not forward any frames.
In blocking state Port performs as follows:

  1.  Discards frames received from the attached segment.
  2.  Discards frames switched from another port for forwarding.
  3.  Does not incorporate the end station location into its address database. (There is no learning on a blocking Layer 2 LAN port, so there is no address database update.)
  4.  Receives BPDUs and directs them to the system module.
  5.  Receives, processes, and transmits BPDUs received from the system module.
  6.  Receives and responds to control plane messages.


Learning State
A port in learning state prepares to participate in frame forwarding by learning the MAC addresses for the frames. The Layer 2 LAN port enters the learning state from the blocking state.
In learning state Port performs as follows:

  1.  Discards frames received from the attached segment.
  2.  Discards frames switched from another port for forwarding.
  3.  Incorporates the end station location into its address database.
  4.  Receives BPDUs and directs them to the system module.
  5.  Receives, processes, and transmits BPDUs received from the system module.
  6.  Receives and responds to control plane messages.


Forwarding State
A Layer 2 LAN port in the forwarding state starts forwarding data frames.
In the forwarding state Port performs as follows:

  1.  Forwards frames received from the attached segment.
  2.  Forwards frames switched from another port for forwarding.
  3.  Incorporates the end station location information into its address database.
  4.  Receives BPDUs and directs them to the system module.
  5.  Processes BPDUs received from the system module.
  6.  Receives and responds to control plane messages.


Disabled State
A Layer 2 LAN port in the disabled state does not participate in frame forwarding or STP. A Layer 2 LAN port in the disabled state is virtually nonoperational.
A disabled Layer 2 LAN port performs as follows:

  1.  Discards frames received from the attached segment.
  2.  Discards frames switched from another port for forwarding.
  3.  Does not incorporate the end station location into its address database. (There is no learning, so there is no address database update.)
  4.  Does not receive BPDUs from neighbors.
  5.  Does not receive BPDUs for transmission from the system module.


Port Cost

Rapid PVST+ uses the short (16-bit) path-cost method to calculate the cost by default. With the short path-cost method, you can assign any value in the range of 1 to 65535. However, you can configure the device to use the long (32-bit) path-cost method, which allows you to assign any value in the range of 1 to 200,000,000. You configure the path-cost calculation method globally.

 


Bandwidth

Short Path-Cost Method of Port Cost

Long Path-Cost Method of Port Cost

10 Mbps

100

2,000,000

100 Mbps

19

200,000

1 Gigabit Ethernet

4

20,000

10 Gigabit Ethernet

2

2,000


STP Config

n7000(config)# vlan 20,30 
      - Make sure you create the VLAN
n7000(config)# spanning-tree mode rapid-pvst
      - Rapid-PVST is the default
n7000(config)# spanning-tree vlan 20 root primary
      - Decrements Priority to 24,596 to increase the probability for it to become root
n7000(config)# spanning-tree vlan 30 root secondary
      - Decrements Priority to 28,672 to increase the probability for it to become the backup for the root


Spanning-Tree Port Types

STP supports three different port types Edge, Network & Normal.
The default port type is normal. An Edge port type can be configured, so an interface immediately forwards traffic (IOS “Portfast”) and the Network port type can be configured to enable Bridge Assurance on an interface.

n7000(config-if-range)# spanning-tree port type ?
 edge     Consider the interface as edge port (enable portfast)
 network  Consider the interface as inter-switch link
 normal   Consider the interface as normal spanning tree port

Only configure ports that connect to a single end station as edge ports.

Understanding Nexus -- Part 13 -- VTP

Now we will have a look at how to configure VLAN Trunking Protocol (VTP) and VTP pruning on Cisco NX-OS devices.

Nexus supports VTP. But depends upon a NX-OS release like what kind of features it will support.

Beginning with Cisco NX-OS Release 5.1(1), VTP and VTP pruning are supported for VTP version 1 and 2.
Before Release 5.1(1), only VTP transparent mode was supported.

VTP info flows through Layer 2 trunk interfaces, Layer 2 trunk port channels, and virtual port channels (vPCs).

There is one more thing which you should keep in mind that, VLAN 1 is required on all trunk ports, if VTP is supported in the network. Disabling VLAN 1 from any of these ports prevents VTP from functioning properly.

All VTP packets received on the Nexus 7000 are dropped by default, if VTP is disabled. This is the default behavior on earlier NX-OS release versions. 
 
Enable VTP in transparent mode to extend a VTP domain through a Nexus. Once, enabled, VTP packets received on a trunk port are relayed to all other trunk ports. 
 
The NX-OS cannot be configured as a VTP client or server today (future feature after Release 5.1(1)).

Lets have a detailed look at VTP configuration parameters.

switch# config t
switch(config)# feature vtp
switch(config)# vtp domain accounting
switch(config)# vtp version 2         --- default is ver 1
switch(config)# vtp mode transparent  --- default server for ver 5.1
switch(config)# vtp file vtp.dat
switch(config)# vtp password cisco
switch(config)# vtp pruning           --- supported from 5.1
switch(config)# exit

Select the VTP domain name and version that match the values used in the existing VTP domain.

VTP Modes

Beginning with Release 5.1(1), VTP is supported in these modes.

Transparent — Mode that allows you to relay all VTP protocol packets that it receives on a trunk port to all other trunk ports
Server — Mode that allows you to create, remove, and modify VLANs over the entire network.  Beginning with Release 5.1(1), the server mode is the default mode. The VLAN information is stored on the bootflash and is not erased after a reboot.
Client — Mode that allows a switch to store the last known VTP information including the configuration revision number, on the bootflash.
Off — Mode that behaves similarly to the transparent mode but does not forward any VTP packets.

VTP allows you to enable or disable the VTP protocol on a per-port basis.

Understanding Nexus -- Part 12 -- VLAN Configs

VLANs provide layer-2 separation boundaries for unicast, multicast, and broadcast packets. Even on Nexus the VLAN configuration is just as same as in IOS.

There are some facts which I would like to update you first.
  • Each VDC supports 4094 VLANs.  VLANs 3968-4047 and 4094 are reserved for internal use.
  • VLANs 1 – 3967 and 4048 – 4094 are configurable (3968-4047 and 4094 are reserved for internal use – The CLI will not let you configure them)
  • VLAN 1 is the default VLAN and cannot be deleted
  • Once a VLAN is created, it automatically goes in the “active” state - Use the shutdown command to disable a VLAN
  • VLAN 1006 – 3967 and 4048 – 4093 cannot be disabled with the shutdown or the state suspend command – they are always “active”
  • When you delete a specified VLAN, the ports associated to that VLAN are shut down and no traffic flows.
  • However, the system retains all the VLAN-to-port mapping for that VLAN, and when you reenable or re-create, that specified VLAN, the system automatically reinstates all the original ports to that VLAN.
  • Commands entered in the VLAN configuration submode are immediately executed.
Here is a short table for your reference.


VLANs Numbers

Range

Usage

1

Normal

Cisco default. You can use this VLAN, but you cannot modify or delete it.

2—1005

Normal

You can create, use, modify, and delete these VLANs.

1006—3967 and 4048—4093

Extended

You can create, name, and use these VLANs. You cannot change the following parameters:
  • The state is always active.
  • The VLAN is always enabled. You cannot shut down these VLANs.

3968-4047 and 4094

Internally allocated

These 80 VLANs and VLAN 4094 are allocated for internal device use. You cannot create, delete, or modify any VLANs within the block reserved for internal use.


Configuring VLAN


There are lot of options you can configure for VLAN. Here is the output for VLAN config-mode.

switch(config)# vlan 10
switch(config-vlan)# ?
  ip              Configure IP features
  media           Media type of the VLAN
  name            Ascii name of the VLAN
  no              Negate a command or set its defaults
  remote-span     Enable remote span VLAN
  service-policy  Configure service policy for an interface
  shutdown        Shutdown VLAN switching
  state           Operational state of the VLAN
switch(config-vlan)# name email-vlan
switch(config-vlan)# state active
switch(config-vlan)# no shutdown
switch(config-vlan)# vlan 11-19         --- To configure a range
switch(config-vlan)# vlan 20,30         --- To configure a range

Understanding Nexus -- Part 11 -- Port-Channel

Port-Channels provide a mechanism for aggregating multiple physical Ethernet links into a single logical Ethernet link. Port-Channels are typically used to increase availability and bandwidth.

Lets look at some facts of Port-Channel :

  • 256 Port-Channels are supported per chassis across all VDCs.
  • You can bundle up to 8 ports into a static port channel without using any aggregation protocol.
  • Ports have to be “compatible” to operate in a Port-Channel. Use the “show port-channel compatibility-parameters” CLI command for verification (~16 compatibility checks)
  • Nexus does not support Port Aggregation Protocol (PAgP) for port channels.
  • To use LACP you must enable it.
  • Up to 16 links can be configured in a LaCP port channel (Only 8 are “active”)

Creating a L2 Port Channel

To create L2 Port-Channel we will enable LACP first and  then create a port-channel
 
switch# configure terminal 
switch (config)# feature lacp
switch (config)# interface port-channel 1

The range is from 1 to 4096.

Adding a Layer 2 Port
 
Now we'll add some L2 interfaces in a created Port-channel
 
switch# configure terminal 
switch (config)# interface ethernet 1/4
switch(config-if)# switchport
switch(config-if)# channel-group 1

Creating a L3 Port Channel
 
Sometimes its necessary to create a L3 Port-channel. The configuration is quite same as in IOS, except we have to add "no switchport" command.

switch# configure terminal 
switch (config)# feature lacp
switch(config)# interface port-channel 4
switch(config-if)# ip address 192.0.2.1/8

Adding a Layer 3 Port
 
switch# configure terminal 
switch (config)# interface ethernet 1/5
switch(config-if)# no switchport
switch(config-if)# channel-group 4

Load Balancing in Port Channels

You can only configure the Load-balancing option in the default VDC.

Port-Channels load balance traffic across all operational links by hashing frame addresses to a numerical value that selects one of the links. You can configure the load-balancing algorithm per “device” or per “module”.
 
dest-ip-port             Destination IP address and L4 port
dest-ip-port-vlan        Destination IP address, L4 port and VLAN 
destination-ip-vlan      Destination IP address and VLAN 
destination-mac          Destination MAC address
destination-port         Destination L4 port
source-dest-ip-port      Source & Destination IP address and L4 port
source-dest-ip-port-vlan Source & Destination IP address, L4 port and VLAN 
source-dest-ip-vlan      Source & Destination IP address and VLAN(Default for IP)
source-dest-mac          Source & Destination MAC address (Default for Non-IP)
source-dest-port         Source & Destination L4 port
source-ip-port           Source IP address and L4 port
source-ip-port-vlan      Source IP address, L4 port and VLAN 
source-ip-vlan           Source IP address and VLAN 
source-mac               Source MAC address
source-port              Source L4 port

Understanding Nexus -- Part 10 -- L3 Interface Configs

Its time to have a glance at L3 interfaces now. You will see the configuration is same just like any L3 interface in IOS.

Routed Interface

All Ethernet ports are routed interfaces by default. You can assign an IP address to the port, enable routing, and assign routing protocol characteristics to this routed interface.
 
switch# configure terminal 
switch(config)# interface ethernet 2/1 
switch(config-if)# no switchport 
switch(config-if)# ip address 192.0.2.1/8 

Subinterfaces
 
Cisco NX-OS enables subinterfaces when the parent interface is enabled. You can shut down a subinterface independent of shutting down the parent interface. If you shut down the parent interface, Cisco NX-OS shuts down all associated subinterfaces as well.

The subinterface range is from 1 to 4094.

switch# configure terminal 
switch(config)# interface ethernet 2/1.1 
switch(config-if)# ip address 192.0.2.1/8 
switch(config-if)# encapsulation dot1Q 33 

Loopback Interfaces

You can configure up to 1024 loopback interfaces per VDC, numbered from 0 to 1023.

switch# configure terminal 
switch(config)# interface loopback 0 
switch(config-if)# ip address 192.0.2.100/8 

VLAN interface 

You must enable the VLAN network interface feature before you configure it.

switch# configure terminal
switch(config)# feature interface-vlan
switch(config)# interface vlan 10
switch(config-if)# ip address 192.0.2.1/8

Understanding Nexus -- Part 9 -- L2 Interface Configs

After the interface Parameters, it’s time to see the L2 configuration. In this post we will discuss about the L2 configuration on an interface… like Access ports, Host ports and Trunk ports.


Layer 2 Access Port

If you want to configure the access port… then it is just like your normal access port on IOS.


 
switch# configure terminal 
switch(config)# interface ethernet 3/1
switch(config-if)# switchport mode access
switch(config-if)# switchport access vlan 5



Host Ports

The Host Port is same as a host port in IOS. For those who don’t understand the host port, it is a port which is connected to a PC or a Server. STP on this interface is disabled. Just like how we configure the port-fast on interface. 

 
switch# configure terminal 
switch(config)# interface ethernet 3/1
switch(config-if)# switchport host

Sets the interface to be an access host port, which immediately moves to the spanning tree forwarding state and disables port channeling on this interface.
Apply this command only to end stations.


Trunk Ports
 
The Trunk Port also is same just as in IOS.



switch# configure terminal 
switch(config)# interface ethernet 3/1
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk native vlan 5
switch(config-if)# switchport trunk allowed vlan 15-20
switch(config-if)# exit
switch(config)# vlan dot1q tag native

If you enable 802.1Q tagging on one device and disable it on another device, all traffic is dropped on the device with this feature disabled. You must configure this feature identically on each device.

Understanding Nexus -- Part 8 -- Basic Interface Configs

The NX-OS supports multiple L2 and L3 Physical Interfaces types to meet various requirements.  All interfaces are in the shutdown state by default.

In NX-OS, all Ethernet interfaces are called “ethernet”, no more FastEtherenet, GigabitEthernet, etc. Also, the keyword “range” is not necessary when configuring a group of interfaces
 
switch(config)# int ?
  cmp-mgmt      CMP management ethernet
  ethernet      Ethernet IEEE 802.3z
  loopback      Loopback interface
  mgmt          Management interface
  port-channel  Port Channel interface
  vlan          Vlan interface

switch(config)# int e10/18 ?
    
  ,      Comma
  -      Hyphen

By default, all ports on the device are Layer 3 ports.

NX-OS provides a configuration to change the default port mode from L3 to L2. Configure the default port mode to L2 then change it back to L3.

The configuration of an interface in default (L3) state :
 
switch# sh run int e1/18
version 4.0(2)

interface Ethernet1/18
  no shutdown

Change the default mode from L3 to L2

switch# config t
switch(config)# system default switchport

The configuration of an interface in L2 state :

switch# sh run int e1/18
version 4.0(2)

interface Ethernet1/18
  no switchport
  no shutdown

Change the default port mode from L2 to L3.
 
switch(config)# no system default switchport


Now lets see the basic interface parameter configuration. These are all same as you see in IOS.
switch# configure terminal 
switch(config)# interface ethernet 3/24
switch(config-if)# description server1
switch(config-if)# speed 1000         --- Speed of Interface 10/100/1000 Mbps
switch(config-if)# duplex full        --- Half/Full Duplex
switch(config-if)# bandwidth 1000000  --- Look at Note.
switch(config-if)# delay 10000        --- Look at Note.
switch(config-if)# no shutdown        --- Enables an interface. Default is Shutdown

NOTE:

The bandwidth as an informational-only value between 1 and 10,000,000.
The command doesn't set BandWidth on interface. Its just an info for routing protocols, so that it can calculate its cost.

The delay time in tens of microseconds.

Understanding Nexus -- Part 7 -- Basic Configs

Ok then. Since now you know all the required things like hardware, software, software user interface, keyboard shortcuts and all… now its time to look at actual configuration.

In this post we will discuss about the very primary things, which you have to configure on any device at the time of deployment. Like Hostname, MOTD, Banner, telnet etc. etc.

1. Hostname

To change the device hostname... The “name” is alphanumeric, case sensitive, and has a length of 32 characters. The default is switch.
 
switch# configure terminal
switch(config)# hostname Engineering2
Engineering2(config)#

2. MOTD Banner

Maximum of 80 characters per line and Maximum of 40 lines
 
switch# configure terminal
switch(config)# banner motd #Welcome to the Switch#
switch# show banner motd

3. Saving the Config
 
Well its pretty same as what we do in IOS.
 
switch(config)# copy running-config startup-config

4. Erasing the Startup Configuration

The “write erase” command erases the startup configuration except the boot variables, mgmt0 interface IP address and subnet mask, static routes in the management vrf context. 
If you want to erase the complete configuration use the “boot” option with the command
 
switch# write erase

5. Telnet / SSH

SSHv2 is enabled by default and is the recommended protocol for CLI remote access.
TELNET is disabled by default since it is less secure.
Both TELNET and SSHv2 clients are supported as well.

Configuring Telnet

switch# configure terminal
switch(config)# feature telnet       --- Enables Telnet
switch(config)# line vty
switch(config-line)# exec-timeout 30
switch(config-line)# exit
switch(config)# copy running-config startup-config

Configuring SSH

switch# configure terminal
switch(config)# no feature ssh       --- Disable SSH & generate RSA key
switch(config)# ssh key rsa 
generating rsa key(1024 bits)......
generated rsa key
switch(config)# feature ssh        --- Re-enables SSH


Thursday, October 28, 2010

Understanding Nexus -- Part 6 -- Keystroke Shortcuts

Now I think it's a time to understand and use some useful things like keystrokes.


Keystrokes

Description

Ctrl-A

Moves the cursor to the beginning of the line.

Ctrl-B

Moves the cursor one character to the left.When you enter a command that extends beyond a single line, you can press the Left Arrow or Ctrl-B keys repeatedly to scroll back toward the system prompt and verify the beginning of the command entry, or you can press the Ctrl-A key combination.

Ctrl-C

Cancels the command and returns to the command prompt.

Ctrl-D

Deletes the character at the cursor.

Ctrl-E

Moves the cursor to the end of the line.

Ctrl-F

Moves the cursor one character to the right.

Ctrl-G

Exits to the previous command mode without removing the command string.

Ctrl-K

Deletes all characters from the cursor to the end of the command line.

Ctrl-L

Redisplays the current command line.

Ctrl-N

Displays the next command in the command history.

Ctrl-O

Clears the terminal screen.

Ctrl-P

Displays the previous command in the command history.

Ctrl-R

Redisplays the current command line.

Ctrl-T

Transposes the character to the left of the cursor with the character located to the right of the cursor.

Ctrl-U

Deletes all characters from the cursor to the beginning of the command line.

Ctrl-V

Removes any special meaning for the following keystroke. For example, press Ctrl-V before entering a question mark (?) in a regular expression.

Ctrl-W

Deletes the word to the left of the cursor.

Ctrl-X, H

Lists the history of commands you have entered.
When using this key combination, press and release the Ctrl and X keys together before pressing H.

Ctrl-Y

Recalls the most recent entry in the buffer (press keys simultaneously).

Ctrl-Z

Ends a configuration session, and returns you to EXEC mode.
When used at the end of a command line in which a valid command has been typed, the resulting configuration is first added to the running configuration file.

Up arrow key

Displays the previous command in the command history.

Down arrow key

Displays the next command in the command history.

Right arrow key
Left arrow key

Moves your cursor through the command history, either forward or backward, to locate a command string.

?

Displays a list of available commands.

Tab

Completes the word for you after entering the first characters of the word, and then pressing the Tab key. All options that match are presented.
Use tabs to complete the following items:
  • Command names
  • Scheme names in the file system
  • Server names in the file system
  • Filenames in the file system
Example:
switch(config)# xm<Tab>
switch(config)# xml<Tab>
switch(config)# xml server

Example:
switch(config)# c<Tab>
callhome class-map clock cts
cdp cli control-plane
switch(config)# cl<Tab>
class-map cli clock
switch(config)# cla<Tab>
switch(config)# class-map

Example:
switch# cd bootflash:<Tab>
bootflash: bootflash://sup-1/
bootflash:/// bootflash://sup-2/
bootflash://module-5/ bootflash://sup-active/
bootflash://module-6/ bootflash://sup-local/

Example:
switch# cd bootflash://mo<Tab>
bootflash://module-5/ bootflash://module-6/cv
switch# cd bootflash://module-

Understanding Nexus -- Part 5 -- CLI Prompt

Once you have successfully accessed the device, the CLI prompt displays in the terminal window of your console port or remote workstation as shown in the following example:
User Access Verification
login: admin
Password:
switch#

The NX-OX CLI shares a lot of concepts as IOS, so initial configuration is very simple. The commands can be abbreviated, the ‘?’ provides online help, and the key auto-fills command option.
EXEC Command Mode
switch#

Global Configuration Command Mode
switch# configure terminal
switch(config)#

Interface Configuration Command Mode
switch(config)# interface ethernet 2/2
switch(config-if)#
Subinterface Configuration Command Mode
switch(config)# interface ethernet 2/2.1
switch(config-subif)#

Exiting a Command Mode
switch(config-if)# exit 
switch(config)# 
 
switch(config-if)# end 
switch# 
 
switch(config-if)# ^z 
switch(config)# 


If you have to see the summary then,



Mode

Access Method

Prompt

Exit Method

EXEC

From the login prompt, enter your username and password.


switch#

To exit to the login prompt, use the exit command.

Global configuration

From EXEC mode, use the configure terminal command.


switch(config)#

To exit to EXEC mode, use the end or exit command or press Ctrl-Z.

Interface configuration

From global configuration mode, use an interface command and specify an interface with an interface command.


switch(config-if)#

To exit to global configuration mode, use the exit command.
To exit to EXEC mode, use the exit command or press Ctrl-Z.

Subinterface configuration

From global configuration mode, specify a subinterface with an interface command.


switch(config-subif)#

To exit to global configuration mode, use the exit command.
To exit to EXEC mode, use the end command or press Ctrl-Z.

VDC configuration

From global configuration mode, use the vdc command and specify a VDC name.


switch(config-vdc)#

To exit to global configuration mode, use the exit command.
To exit to EXEC mode, use the end command or press Ctrl-Z.

VRF configuration

From global configuration mode, use the vrf command and specify a routing protocol.


switch(config-vrf)#

To exit to global configuration mode, use the exit command.
To exit to EXEC mode, use the end command or press Ctrl-Z.

EXEC for a nondefault VDC

From EXEC mode, use the switchto vdc command and specify a VDC.


switch-vdc2#

To exit to the default VDC, use the exit command or the switchback command.

EXEC for a nondefault VRF

From EXEC mode, use the routing-context vrf command and specify a VRF.


switch%red#

To exit to the default VRF, use the routing-context vrf default command.

Understanding Nexus -- Part 4 -- Overview of NX-OS


As you see understanding of hardware is a essential stuff… but software understanding is mandatory to run that particular hardware. Here is the same case… Now since we know the hardware its time to have a look at software.

The Cisco NX-OS is same as IOS… with lot of modifications. It’s a highly available and modular operating system designed specifically for the Data Center. It supports Layer 3 Routing, Layer 2 Bridging and  SAN Switching (Storage). It also supports virtualization.

ISSU
In Service Software Upgrade. Well this is something great feature Cisco came up with. Now you can upgrade your NX-OS on a live Nexus Switch while its in a service. You don’t have to worry about your Data Traffic. It will keep flowing :-)

Support for Storage Protocols
Previously 6500 used to support L2 switching and L3 Routing only. All the storage switches were separate. Now Cisco has came up with one more feature… They have integrated the protocols which are required for storage  in NX-OS itself. For those who are not aware of storage switches, have you heard or Brocade? Well, now you don’t need those extra switches. Only thing is you have to upgrade your Lic for NX-OS to support storage protocols.

Command Line Interface (CLI)
Cisco has kept the Look-and-Feel of IOS in the NX-OS with many enhancements. The architecture of OS is changed a lot.
  • You can execute show commands in any mode now… with parser help even in configuration mode.
  • “Slash” notation supported for all IPv4/IPv6 masks. You can use “/” while assigning ip address on the interface or in a static route command ;-)
  • key displays brief list of all available options of the commands
  • ? key help is still available.
  • Variety of pipe options for CLI output including grep, less, no-more etc… just like your unix.
  • Multiple levels of pipe options are available.

Understanding Nexus -- Part 3 -- SUP & Modules

Supervisor Engine of Nexus is just like 6500 SUP... With many changes, ofcourse.
The Nexus SUP has,
1. 4 GB DRAM,
2. 2 GB Internal BootDisk (8 GB Log & 2 GB Expansion), 
3. 2 MB NVRAM
4. Dual Core Processor






For External Connections
1. 1 “10/100/1000” Ethernet Mgmt Port, 
2. 1 Console Port  & 1 Auxiliary Port 
3. 1 CMP 10/100/1000 Ethernet Port 
4. 3 USB Ports (2 host – 1 device)
5. 2 external compact flash slots


Management Interface
It is a Out-of-band 10/100/1000 management interface means, if you are sitting in DataCenter you can have a separate network just for Management. All our PC's will be connected to this interface. As shown in the diagram...






Connectivity Management Processor (CMP)
It's a Standalone, “always on” management processor on supervisor engine with a separate interface for its own connection.

CMP has its own RAM & boot flash, front panel 10/100/1000 Ethernet port and it can access to the I/O (console/serial) ports. It has its own power management. CMP runs lightweight Linux kernel and network stack, which is Completely independent of NX-OS on main CPU.

It's used to
- provide remote connectivity to the Supervisor card via telnet or ssh
- monitor the health of the CPU on the Supervisor card
- monitor (view) the output on the Supervisor console port
- you can log the output and take full control of the Supervisor console port
- you can reset Supervisor Console Port if hung


Modules
- 32-Port 10GE I/O Module with SFP+ transceivers. This card has group interfaces. It has group of 4 interfaces. So total 8 Groups. Each group has 10G bandwidth allocated which shared among all 4 interfaces in the group. If you want to use complete 10G on a single interface then you have to use the first port (highlighted with yellow) in the group.
- 48-Port 10/100/1000 I/O Module with all RJ-45 interfaces.
- 48-Port 1G I/O Module with all SFP interfaces.